20/9/10

Ubuntu no arranca, ni en modo grafico ni recovery



Hace unos dias mientras actualizaba mi Ubuntu 10.04 pensé que se habia quedado colgado ya que la consola no me daba ningún tipo de mensaje, en fin que iluso de mí le dí al botón del "reset" de mi pc. Inicio de nuevo el ordenador y ¡Hala! ya no me inicia mi linux, ni en modo grafico ni recovery ¿que hago? Pues bien lo 1º buscar y mucho por la red (antes de preguntar siempre es mejor hacerlo) pero no daba con el resultado, nada me servía, así que pensé que al final me tocaría formatear pero no. Gracias a este magnífico blog y con la ayuda prestada en su foro me ayudaron a resolverlo.

así que copio y pego el resultado  (gracias juanetebitel).



Crea estos directorios:

sudo mkdir /media/lucid

sudo mkdir /media/lucid/proc /media/lucid/dev /media/lucid/etc


Monta la partición donde tengas ubuntu (por ej /dev/sda6)

sudo mount /dev/sda6 /media/lucid

Enlaza los directorios:

sudo mount -o bind /proc /media/lucid/proc

sudo mount -o bind /dev /media/lucid/dev/

sudo mount -o bind /dev/pts /media/lucid/dev/pts


Copia este archivo:

sudo cp /etc/resolv.conf /media/lucid/etc/resolv.conf

Actualiza los repositorios de la partición real con chroot:

sudo chroot /media/lucid apt-get update

Este paso hazlo sólo si te responde: "E: dpkg se interrumpió, debe ejecutar manualmente «sudo dpkg --configure -a» para corregir el problema", si no pasa al siguiente paso.

sudo chroot /media/lucid dpkg --configure -a

Actualiza el sistema de la partición real con chroot:

sudo chroot /media/lucid apt-get dist-upgrade

Arreglamos paquetes rotos:

sudo chroot /media/lucid apt-get -f install

Reinicia.
Espero que os sea tan útil como a mí.

Que os vaya bonito.

20 comentarios:

  1. A mi me pasa algo parecido.Primero no podía apagar ubuntu 10.10 de ninguna forma ni siquiera desde el terminal,la única manera era aprentando on/off.Después sudo gedit /etc/modules y agragar apm power_off=1. Luego guardar y reiniciar.después de reiniciar varias veces y ver que no se solucionaba ahora ya no arranca ni en recovery nada de nada pantallazo.He seguido estas instrucciones desde liveusb pero nada de nada y lo peor es que por pereza no hice una partición / raiz y otra home osea que me va ha tocar pasar casi 200 gb a disco duro y formatear.Porque ya no le veo esperanza.

    ResponderEliminar
  2. HOla
    lamento que no te funcione este post, por cierto ¿te lanza algún mensaje la consola? si es así ¿cual?. si me dices también algo del pc (gráficas, etc) a lo mejor podemos hacer algo.

    Y como dices SIEMPRE ES MEJOR montar una partición /home para poder restaurar sin perder datos.
    Ya me diras.
    Saludos

    ResponderEliminar
  3. A lo mejor esto te sirve, ya que parece que la versión 10.10 de ubuntu está dando muchos problemas en ese sentido. Mira aquí.

    http://www.ubuntu-es.org/node/142729#comment-406103

    si lo solucionas confirmalo por favor.
    gracias.

    ResponderEliminar
  4. Muchas Gracias KsauKao me voy a poner en eso ahora.En un rato me paso y comento.Quería añadir que uso ubuntu desde gutsy y nunca me ha dado problemas por eso me extraña esta situación.

    Saludos y gracias hasta ahora!!!!!!

    ResponderEliminar
  5. La verdad es que ubuntu siempre a sido un sistema muy estable, pero ya se sabe ... a veces las prisas son malas consejeras y eso parece que a pasado un poco con la la Maverick . Espero puedas solucionarlo y gracias por tu comentario.

    nos vemos

    ResponderEliminar
  6. Hola KsauKao,me pasé por el enlace pero ya lo había probado el tema es que ya no podía iniciar ni en modo recovery.Al final he hecho un pequeño arreglo de la siguiente forma:

    Yo tenía el grub con Win 7 , ubuntu y Backtrack lo que he hecho es con el instalador de ubuntu liberar 20 Gb de espacio de la partición backtrack.En estas 20gb he montado / raiz y en sda5 donde estaba ubuntu he montado Home sin formatear.Lo he hecho para salir del paso y cuando tenga más tiempo le pegaré una limpieza y reestructuración.

    Bueno saludos y un placer!!!!!

    ResponderEliminar
  7. Bueno a sido una solución, veo que te has adaptado al problema y has salido airoso. Como dices lo mejor es más adelante dejarlo impecable.

    Por cierto el placer ha sido mio.
    a cuidarse

    ResponderEliminar
  8. Te felicito KsauKao por el blog y creo que es importante dar facilidades para que la gente que no ha probado linux vayan acercándose a este gran O.S.

    Seguro nos volvemos a encontrar!!!!

    ResponderEliminar
    Respuestas
    1. Muchisimas gracias por tu comentario amigo anónimo.

      Eliminar
  9. A mi me ha funcionado.
    Mil gracias

    ResponderEliminar
    Respuestas
    1. Me alegro que te haya sido útil.
      Gracias por compartirlo.
      Un saludo

      Eliminar
  10. a mi me pasa que no se nada lo instale con xp me dio muchos problemas hacer que arranque como predeterminado despues que lo logre entre se puso a descargar no c que y cundo finaliso no me tomaba ni el teclado ni el mouse y no me dejaba salir del sistema tube que apagar abruptamente
    ahora cuando prende me da opciones pero no puedo eleguir ninguna y se pasa el tiempo de espera arranca y se queda trabado en una pantalla bordo sin nada y el mouse lo veo poro no se mueve nesesito ayuda como puedo entrar por los bios para que window arranque como predeterminado y no ubuntu mi msn es tadeo2221@hotmail.com por favor nececito ayuda gracias....

    ResponderEliminar
    Respuestas
    1. Para que te arranque xp o ubuntu, no tiene nada que ver la bios, a menos que estén instalados en discos diferentes de un pc.

      Si están en el mismo disco lo que te falla es el sector de arranque.

      Aún así, no entiendo muy bien el problema ni qué lo provoca.

      Saludos

      Eliminar
  11. yo la verdad que cuando lei "para niños " dije bueno aca esta voy a comprender pero enmpece a leer y siempre igual 1ro) utilizan palabras que solo quien esta adelantado en esto entiende ,grub., sda 5,montaje, esto entoncs deja de ser para niños y es para experimentados 2do) tengo un año y pico de estudio de informatica pero siempre veo lo mismo una gran incapacidad para enseñarla. desde cero por supuesto no digaamos esos cursos que son para quienes tienen slgo e conocimiento hasta ahora la erscuela no me sirvio de mucho los profesores me parecio que hacen "lo que pueden o saben" (hay que comer) y pareciera que esto requiere una revolucion didactica urgente para que cambie de lo contrario seran menos los que realmente sepan manejar ,arregalar. y explicar los fundamentos de una computadora lamentablemente esto arrastra cierto sentimiento de frustracion para mucha gente que huye de la informatica pero que quiere saber y aplicar mas en la maquina que meros jueguitos de guerra o chatear con el vecino

    ResponderEliminar
    Respuestas
    1. Saludos amigo anónimo.
      Gracias por compartir tu opinión respecto al blog, tan respetable como cualquier otra.
      Permiteme, sin embargo, aclarar un punto que creo que es importante.
      Este blog y la información que contiene no es para niños, sino que la información, tutoriales y demás están ( o lo procuro al menos) explicados como para niños, es decir, intento que la información que comparto se llana, clara, y sencilla.
      Eso no quita que, pese a todo, en ocasiones no lo logre ( mea culpa ), y que en otras haya conceptos o palabras en los que no pueda simplificar más.
      "Explicado como para niños" continua siendo un blog sin pretensiones, comparto lo que aprendo para familiares y amigos, no estoy relacionado con la docencia y con la informática a nivel profesional, y cada dia aprendo algo más.
      Aquí tenemos un refrán que dice así :El que hace lo puede no está obligado a más.

      Un cordial saludo

      Eliminar
  12. Anónimo6/8/13 6:11

    buenas, he echo todos los pasos, pero al actualizar los repositorios
    sudo chroot /media/lucid apt-get update
    me salta
    W: No pude leer /etc/apt/apt.conf.d/ - DirectoryExists (2: No existe el archivo o el directorio)
    W: No pude leer /etc/apt/sources.list.d/ - DirectoryExists (2: No existe el archivo o el directorio)
    W: No pude leer /etc/apt/sources.list - RealFileExists (2: No existe el archivo o el directorio)
    E: Falta el directorio de listas /var/lib/apt/lists/partial. - Acquire (2: No existe el archivo o el directorio)

    lo que conlleva a que cuando reinicio la pc sigo sin poder entrar a mi ubuntu. Ojala me puedas ayudar . Saludos

    ResponderEliminar
    Respuestas
    1. Debes poner tu versión de Ubuntu, en mi caso era 10.04 pero la tuya puede ser otra

      Eliminar
  13. Hola no se si me podrias ayudar instale ubuntu 13.10 de 64 bits pero al instalarle drivers privativos ahora solo me muestra una pantalla negra que tiene del lado izquierdo algo asi como tareas y del lado derecho puros [OK] ,le instale esos driver por que en juegos me andaba a 3 fps con los de drivers de codigo abierto.
    No me deja entrar al grub apretando shift , hay alguna otra manera de entrar a la consola?
    Mi notebook es una Acer Aspire 4520 y tiene una grafica nvidia 7000m
    Gracias de antemano

    ResponderEliminar
    Respuestas
    1. Hola Arzibel.
      Para entrar en la terminal (tty) haz lo siguiente:
      Ctrl+Alt+F1 para entrar (te pedirá tu login y contraseña)
      Ctrl+Alt+F7 para volver al entorno gráfico.

      Elimina los drivers propietarios:
      sudo apt-get remove nvidia-current nvidia-current-updates nvidia-experimental-304

      Te dejo un artículo muy útil sobre el tema.
      Instalar controlador privativo Nvidia

      Saludos

      Eliminar
  14. Buenos dias KsauKao,
    Lo primero comentar que no sé si este es el hilo para hacver mi consulta, pero soy un novato de Linux y he instalado Ubuntu 13.10 en un HP-mini que tenía Win 7 e iba demasiado lento. La cosa fue genial hasta que ayer, me ofreció actualizar a Ubuntu 14.4, me dijo que no tenía suficiente espacio disponible, seguí unos consejos para liberarlo, pero no pude actualizar. Cuál es mi sorpresa, que al reiniciar el PC, en la pantalla en negro aparecen un montón de órdenes y las luces del Bloq Mayúsculas parpadean y no puedeo acceder a nada.
    Este es el mensaje final que me muestra:
    2.489067] --- [end trace8344 eb0e429c1a2b ] ---

    Espero que puedas ayudarme
    Muchas gracias!!!!

    ResponderEliminar

¿Algo que decir, preguntar, o consultar? No te cortes.

LinkWithin

Related Posts with Thumbnails