2/12/11

Actualiza openSUSE 11.4 a 12.1


Saludos.

Ya han pasado unos días desde la publicación  de openSUSE 12.1, con lo que he decidido a actualizar el sistema a la nueva versión.

¿Como hacerlo?, veréis que no es difícil, aunque en esta ocasión parte de la misma la he tenido que combinar el uso de "Yast" con la consola.



 Abrimos la terminal y escribimos:


zypper refresh 
zypper update 
zypper modifyrepo --all --disable

Con esto ya hemos desactivado los repositorios de la versión que estemos usando. El siguiente paso es agregar los de la versión 12.1 así que abrimos el "Yast" y escogemos la opción "Repositorios de software" luego a "Añadir" y finalmente la opción "Especificar URL".

http://download.opensuse.org/distribution/12.1/repo/oss
http://download.opensuse.org/distribution/12.1/repo/non-oss
http://download.opensuse.org/update/12.1

Lo debemos hacer por este orden. Luego le damos a "Actualizar" y con eso tenemos los repositorios listos para actualizar.

Solo nos queda abrir la consola y escribir:

zypper dup


y dependiendo de nuestra velocidad de conexión y pc en 2 horas lo tendréis listo.

Que os vaya bonito.

Unas capturas.

11.4 


versión 12.1








42 comentarios:

  1. Hola, gracias por tus explicaciones, tengo una duda, a ver que me puedes decir al respecto...que pasa con la configuración del Grub ( tengo el OS oscuro tb) y la configuración del fstab? los permisos de acceso escritura y tal continúa igual como en las debianitas o hay que empezar a configurar TODO desde el principio? Nunca he actualizado una distro de openSUSE y tengo varias particiones de las cuales una de ellas tiene toda la carrera en archivos es decir, no puedo perderlo xq me va la vida en ello...que me dices? Gracias otra vez Ksaukao

    ResponderEliminar
  2. Hola Sdum

    yo he actualizado varias veces openSuSe sin tener ningún tipo de problemas. Ahora bien, hay dos aspectos que a mi parecer hay que tener muy encuenta:

    1) Hace una copia de respaldo de los datos más importantes (obligatorio para evitar lamentaciones)

    2) Es muy aconsejable tener tener el "Home" en una partición aparte (una opción muy a tener en cuenta)

    Por lo demás no tendrás que configurar nada si la actualización a ido de forma correcta.

    Un saludo

    ResponderEliminar
  3. Hola a todos, a ver si alguno de ustedes puede ayudarme con esto, intente actualizar opensuse tal como viene explicado aquí, después de una hora de instalación aparecen los siguientes errores en la consola:

    Descargando paquete bind-libs-9.8.1P1-4.6.1.i586 (700/1406), 854,0 KiB (2,9 MiB desempaquetado)
    rpmdb: page 1: illegal page type or format
    rpmdb: PANIC: Argumento inválido
    rpmdb: Packages: pgin failed for page 1
    error: db3 error(-30977) de dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db3 error(-30977) de db->open: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db3 error(-30977) de db->close: DB_RUNRECOVERY: Fatal error, run database recovery
    error: no se pudo abrir índice Name utilizando db3 - (-30977)
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db3 error(-30977) de db->close: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db3 error(-30977) de dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
    Obteniendo: bind-libs-9.8.1P1-4.6.1.i586.rpm [hecho (262,8 KiB/s)]
    Instalando bind-libs-9.8.1P1-4.6.1 [error]
    La instalación de bind-libs-9.8.1P1-4.6.1 ha fallado:
    (con --nodeps --force) Error: Subprocess failed. Error: RPM fallido: warning: waiting for exclusive lock on /var/lib/rpm/Packages
    error: cannot get exclusive lock on /var/lib/rpm/Packages
    error: cannot open Packages index using db4 - Operation not permitted (1)
    error: cannot open Packages database in /var/lib/rpm

    Después al reiniciar aparece este mensaje y ya no hace nada mas:
    Kernel panic - not syncing:Attempted to kill init!

    ¿Alguien sabe que podría ser?

    Saludos.

    ResponderEliminar
  4. Soy el del comentario anterior, disculpen pero no soy bueno en ingles, ¿Acaso el sistema me esta pidiendo que corra el recuperador de base de datos?

    No entiendo muy bien de que se trata, y hasta el momento no consigo arrancar el sistema pues siempre que lo hago me aparece ese mensaje de kernel panic y ya no responde a nada.

    Agradezco cualquier ayuda.

    ResponderEliminar
    Respuestas
    1. Hola Jose
      parece que te ha dado un error al instalar un paquete, bind-libs-9.8.1P1-4.6.1.i586 para ser exacto.
      Prueba a instalarlo desde la consola.
      Para ello, como el gestor de ventanas no te funciona, usa las tty (hazlo mediante la combinación de teclas Ctrl+Alt+F1), lo instalas, lo refrescas y actualizas con "zypper refresh
      zypper update " a ver si funciona. Recuerda que para volver al gestor de ventanas o salir del tty has de usar la combinación Ctrl+Alt+F7
      Espero haberte ayudado, aunque mis conocimientos en openSuSe son limitados (continúo aprendiendo igual que con Ubuntu y compartiendo lo que aprendo).
      Un cordial saludo.

      Por cierto un foro en castellano para opensuse en http://www.forosuse.org/forosuse/

      Eliminar
  5. Anónimo7/2/12 19:10

    Excelente guia!, actualizado sin problemas!

    ResponderEliminar
    Respuestas
    1. Muchísimas gracias por comentarlo en el blog.
      Un saludo.

      Eliminar
  6. Ha funcionado de lujo, me he ahorrado un rato de instalación, muchas gracias.

    ResponderEliminar
    Respuestas
    1. Hola Hugo, me alegro de haberte ayudado con la información, y gracias por comentarlo.
      Un saludo

      Eliminar
  7. Hola en la web de opensuse descargue la version de KDE, no entiendo por que es la 11.4 si ya esta la 12.1 pero en fin, quisiera actualizar a la 12.1, no afecta en nada al controlador de mi tarjeta grafíca es una Nvidia geforce 8400gt, o si es posible que me dijeras donde puedo saber como conertir SUSE en tumbleweed, gracias de antemano...

    ResponderEliminar
    Respuestas
    1. HOla Jack
      te dejo este enlace donde puedes descargar la versión 12.1, desde que hice el artículo siempre se ha podido descargar esta versión, pero si no te sale le das al desplegable, y escoges la versión y el modo de descarga.
      En cuanto al controlador de la Nvidia no debes tener problemas ya que, si está soportado en tu versión, tambien lo estará en la 12.1.

      openSuSe 12.1
      Un saludo

      Eliminar
    2. Muchas gracias ya lo instale y me fue a la perfección, lo de la tarjeta incluso fue más fácil, ya que en la 11.4 la tuve que instalar aparte y en la 12.1 me la instalo junto con el sistema, Gracias!!!

      Eliminar
    3. Me alegro Jack que todo te haya ido perfecto. Bienvenido al mundo de openSuSe
      Un saludo

      Eliminar
  8. Hola! Soy Esther, muy útil tu blog!
    Soy usuaria de linux, pero no muy entendida en todo el tema de instalación. En mi portátil me instalaron opensuse 11.3 y está más que obsoleto, imposible actualizar nada... He visto esta guía para actualizar desde la versión 11.4, pero no tengo claro si podré hacerlo de igual manera desde la 11.3 o si ya el cambio de 11.3 a 11.4 fue tan sustancial que lo más conveniente es instalarlo todo de nuevo. Y otra pregunta: tengo tarjeta nvidia y funciona ahora perfectamente, pero miedo me da que deje de funcionar con la actualización...

    Gracias por tu ayuda!

    ResponderEliminar
    Respuestas
    1. Hola Esther
      gracias por tu comentario del blog. En cuanto a tu consulta, te sugiero que primero actualices a 11.4,(tengo una guia en el blog), luego sí podrás actualizar a 12.1
      En cuanto a la nvidia, yo tengo una y no tengo problemas. Ahora que la versión 12.1 está más madura y es un buen momento para actualizar. Es bueno no tener prisas a la hora de cambiar de versión.,a menos que nos guste trastear y asumir algunos riesgos.
      espero haberte sido de ayuda, para cualquier duda, aqui estamos.
      un saludo

      Eliminar
  9. Que tal,un detalle luego de la actualizacion a 12.1 es que el touchpad no funciona. Que debo hacer para solucionarlo.

    ResponderEliminar
    Respuestas
    1. Hola Diego.
      ¿que portátil tienes? Marca, modelo, etc...
      A ver si le podemos buscar una solución.
      Un saludo

      Eliminar
    2. Tambien puedes probar esto

      YaST → Instalar / desinstalar software → buscar synaptiks y en la pestaña Versiones seleccionar aquella del repositorio OSS

      Eliminar
  10. Anónimo26/4/12 7:15

    Que tal esta muy bien explicado el tuto, jeje como dices explicado para niños, pero tengo un problema al tratar de agregar algun repositorio me sale conection failed seguido por una direccion en formato IPV6 y que compruebe la conetividad con el servidor, sabes porque pasa esto, supongo yo que los servidores no estan en linea ???? Gracias de antemano

    ResponderEliminar
    Respuestas
    1. Saludos.
      1º gracias por tu comentario
      2º en cuanto a tu problema no te puedo contestar ahora mismo, ayer actualicé el sistema y ahora no me inicia ( lo hago desde ubuntu), en cuanto lo solucione te miro tu error, que en principio parece que te coge mal el protocolo de red (debería ser IPV4) mira a ver si cambiando la configuración de red lo solucionas.

      Tanto si lo solucionas como si no, puedes comentarlo ya que si es ese el problema otros se pueden encontrar en el mismo contratiempo y sabrán la solución, y si no ya la buscaremos aquí.
      Un saludo

      Eliminar
    2. Para hacer tener compatible los dos protoclos haremos lo siguiente:
      Yast -- Ajustes de red -- Pestaña "Vista Resumen" -- botón "Editar" --
      -- y en el despegable "Use los valores iBTF" escoger la opción "DHCP versiones 4y6"


      Con esto, en principio, nuestra tarjeta de red debe soportar ambos protocolos sin darnos problemas en los repositorios.
      Un saludo

      Eliminar
  11. Anónimo19/5/12 0:03

    Tengo un problema, actualice y no me dio ningun error, pero no logro salir a internet desde el sistema operativo, es decir desde la consola, el yast, etc. yo me conecto a internet a traves de proxy, ya el proxy esta configurado, deshabilite el firewall y el apparmor y nada, si hago la prueba del proxy desde el yast me dice que hay conexion y tengo configurado el mozilla con el mismo proxy y sale a internet normalmente. alguna ayuda?

    ResponderEliminar
  12. Buenas. Entiendo por lo que dices, que con Firefox puedes navegar por internet sin problemas, pero el sistema no, es decir no puedes actualizar, etc.... Utilizando en todos los casos la misma configuración de proxy ¿es correcto?
    Saludos

    (Yo no me conecto mediante proxy pero puedo mirarlo a ver como lo solucionamos)

    ResponderEliminar
  13. así es, desde el navegador todo correcto, pero desde el sistema no, y es la misma configuración en ambos casos.

    ResponderEliminar
    Respuestas
    1. bueno y la actualizacion de 11.4 a 12.1 la hice estando detrás del proxy y todo funcionaba bien, fue una vez ya actualizado a 12.1 que dio el problema, por eso lo primero que se me ocurrió es que con la actualización se haya activado algun servicio de seguridad que me bloqueara la salida a través del proxy, por eso deshabilite el firewall y el apparmor.

      Eliminar
    2. En esta web he encontrado información de como configurar el proxy en openSuSe, aunque está en inglés es muy intuitivo y con imágenes. Espero que te sirva.
      Un saludo

      Eliminar
    3. Anónimo22/5/12 0:55

      el proxy ya lo tenia configurado, la configuracion esta correcta, de hecho en modo grafico tenes el proxy test para comprobar que hay salida a internet, y el resultado es que tengo conexion. otra idea?? :s

      Eliminar
    4. La verdad es que no se me ocurre nada respecto al problema que comentas, también es verdad que al no haber trabajado nunca detrás de un proxy mi experiencia en este sentido es prácticamente nula.
      Lamento no ser de más ayuda.
      Un saludo

      Eliminar
    5. En el foro suse hay un tema similar. A ver si te es útil, y lo comentas.
      Un saludo

      Eliminar
    6. sigo con problemas... aunque ahora he llegado a pensar que es un problema con los respositorios, ya que hice la prueba wget google.com... y me bajo el index... es decir hay salida desde el sistema... si ocupo el yast para bajar algun paquete el error es como que no encontrarara la siguiente ruta http://download.opensuse.org/update/12.1/repodata/repomd.xml, en cualquiera de los repositorios es lo mismo aparentemente busca ese archivo repomd.xml y no lo encuentra

      Eliminar
    7. Amigo anónimo, si que te está dando problemas.....
      A ver si esto te sirve ya que es un caso similar al tuyo.
      Un saludo.

      Error con repositorios

      Eliminar
    8. Anónimo26/5/12 1:22

      finalmente una luz al final del camino!!!!, resulta ser que ocupe el sudo, sudo zypper ref... y todo funciono correctamente, instale algunos paquetes y todo perfecto... quiere decir que es un problema con los privilegios, lo cual no entiendo ya que estoy entrando como root.

      Eliminar
    9. Me alegro que lo hayas solucionado, y sobretodo que lo hayas compartido aquí con nosotros, ya que si alguien se encuentra en la misma situación puede tener una idea de la solución.
      Investigaré un poco más sobre este tema.
      Un saludo

      Eliminar
    10. bueno y pues gracias porque los foros que recomendaste me ayudaron, para probar y eliminar hipotesis, finalmente probe sudo por el foro porque no acostumbro ocuparlo debido a q trabajo en el root para las configuraciones.

      Eliminar
    11. Ha sido un placer haber podido ayudar.

      Un saludo

      Eliminar
  14. Hiii
    Pregunta. Esto es igual de seguro o mejor que pre-upgrade de fedora???

    ResponderEliminar
    Respuestas
    1. Quiero decir, si tiene problemas con la actualizacion o algo en especial :D

      Eliminar
    2. Como puedes ver, por los comentarios de algunos usuarios, la actualización no le ha dado problemas a la mayoría de ellos. Además la versión 12.1 esta más madura y por lo tanto la posibilidad de conflictos es menor.
      Un saludo

      Eliminar
    3. Gracias por responder :D
      Lo digo por que estoy en la 12.1 y para la siguiente no quiero reinstalar con 12.2.

      Jejeje esque vendo de Arch y estoy acostumbrado a lo Rolling Release.
      Que tal esta la Rolling de openSUSE

      Eliminar
    4. ¿Vienes de Arch? eres un crack!!! jejeje
      La rolling todavía no la he probado
      Un saludo

      Eliminar
  15. actuakizé opensuse 11.4 pero se desactivó el teclado y el mouse. cómo lo activo?

    ResponderEliminar
    Respuestas
    1. ¿openSUSe no te reconoces los dispositivos? es raro, para descartar que sea de suse ¿ has probado otro teclado o ratón diferente?

      Eliminar

¿Algo que decir, preguntar, o consultar? No te cortes.

LinkWithin

Related Posts with Thumbnails